Welcome! Log In Create A New Profile

Advanced

Re: [alert] 17289#0: open socket #14 left in 39 connection

Neelesh Gurjar
March 16, 2009 10:11PM
Hi Jeroen,

A. Can you try following changes in your ngix.conf ?

1. Comment following lines:
client_body_buffer_size 8k;
client_header_buffer_size 1k;
client_max_body_size 1k;
large_client_header_buffers 1 1k;
client_body_timeout 5;
client_header_timeout 5;

2. Change following settings:
user www
worker_connections 2048;

3. Enable logging error & access both logs

B. Are you using php+fastcgi? If yes then please see that whether it is
running & configured with ngix properly or not?

Hope it will help you.

Regards
NeeleshG

On Mon, Mar 16, 2009 at 10:30 PM, Jeroen Steggink - CMS <webmaster@cmsnl.com
> wrote:

> Hi NeeleshG,
>
> These are the relevant settings:
>
> user www www;
> worker_processes 2;
>
> events {
> worker_connections 1024;
> }
> ## Size Limits
> client_body_buffer_size 8k;
> client_header_buffer_size 1k;
> client_max_body_size 1k;
> large_client_header_buffers 1 1k;
>
> ## Timeouts
> client_body_timeout 5;
> client_header_timeout 5;
> keepalive_timeout 5 5;
> send_timeout 5;
>
> ## General Options
> ignore_invalid_headers on;
> limit_zone gulag $binary_remote_addr 1m;
> recursive_error_pages on;
> sendfile on;
> server_name_in_redirect off;
> server_tokens off; # hides version numbers
>
> ## TCP options
> tcp_nodelay on;
> tcp_nopush on;
>
> Cheers,
>
> Jeroen
>
> ------------------------------
> *From:* owner-nginx@sysoev.ru [mailto:owner-nginx@sysoev.ru] *On Behalf Of
> *Neelesh Gurjar
> *Sent:* maandag 16 maart 2009 17:31
> *To:* nginx@sysoev.ru
> *Subject:* Re: [alert] 17289#0: open socket #14 left in 39 connection
>
> I faced same problem in the begining. However it got resolved after setting
> following parameters properly:
>
> user, worker_processes, worker_connections, keepalive_timeout, tcp_nopush,
> tcp_nodelay
>
> Please post your ngix.conf to get the better idea.
>
> Regards
> NeeleshG
>
>
> On Mon, Mar 16, 2009 at 6:06 PM, Jeroen Steggink - CMS <
> webmaster@cmsnl.com> wrote:
>
>> Hello,
>>
>> I have installed Nginx 0.6.35 and got the following error:
>>
>> [alert] 17289#0: open socket #14 left in 39 connection
>>
>> After this error, the server crashed. At the time the server was under a
>> high load with high disk I/O.
>>
>> This is what 'nginx -V' returns:
>>
>> nginx version: nginx/0.6.35
>> built by gcc 4.1.2 20080704 (Red Hat 4.1.2-44)
>> configure arguments: --with-cpu-opt=amd64 --without-http_autoindex_module
>> --without-http_fastcgi_module --without-http_proxy_module
>> --with-http_ssl_module --with-http_stub_status_module
>> --without-http_ssi_module --without-http_userid_module
>> --add-module=/root/nginx-geoip-0.1 --with-md5=/usr/lib64
>> --with-sha1=/usr/lib64 --prefix=/opt/nginx --sbin-path=/usr/sbin/nginx
>> --conf-path=/etc/nginx/nginx.conf --pid-path=/var/run/nginx.pid
>> --http-log-path=/var/log/nginx/access.log
>> --error-log-path=/var/log/nginx/error.log --lock-path=/var/lock/nginx.lock
>> --user=www --group=www
>>
>> What could be the problem?
>>
>> Kind regards,
>>
>> Jeroen
>>
>
>
>
> --
> Regards
> NeeleshG
>
> LINUX is basically a simple operating system, but you have to be a genius
> to understand the simplicity
>
>


--
Regards
NeeleshG

LINUX is basically a simple operating system, but you have to be a genius to
understand the simplicity
Subject Author Posted

Re: [alert] 17289#0: open socket #14 left in 39 connection

Neelesh Gurjar March 16, 2009 10:11PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 89
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready