Welcome! Log In Create A New Profile

Advanced

NGINX and WordPress help...An Unexpected HTTP Error

November 12, 2010 12:27PM
Getting a strange error when I try to browse to the install pages on my site's wp-admin, running 32-bit Arch, NGINX 0.8.53, PHP 5.3.3 (fpm-fcgi), and so far I've tried this on WP 3.0.0 and 3.0.1.

[code]An Unexpected HTTP Error occurred during the API request.[/code]

The common solution (which did not work for me...or a litany of other users according to what I've found on google) is to change the timeout in wp-includes/class-http.php to something greater than or equal to 30 seconds:

[code]'timeout' => apply_filters( 'http_request_timeout', 5)[/code]

After changing this setting I cleared my browser's cache and still received error.

Here is my nginx.conf:

[code]user nginx nginx;
worker_processes 1;
pid /var/run/nginx.pid;

events {
worker_connections 1024;
}

http {
set_real_ip_from 204.93.240.0/24;
set_real_ip_from 204.93.177.0/24;
set_real_ip_from 199.27.128.0/21;
real_ip_header CF-Connecting-IP;

include mime.types;
default_type application/octet-stream;

log_format main '$remote_addr - $remote_user [$time_local] '
'"$request" $status $bytes_sent '
'"$http_referer" "$http_user_agent" '
'"$gzip_ratio"';

client_header_timeout 3m;
client_body_timeout 3m;
send_timeout 3m;

client_header_buffer_size 1k;
large_client_header_buffers 4 4k;

gzip on;
gzip_min_length 1100;
gzip_buffers 4 8k;
gzip_types text/plain;

output_buffers 1 32k;
postpone_output 1460;

sendfile on;
tcp_nopush on;

tcp_nodelay on;

keepalive_timeout 75 20;

include /etc/nginx/sites-enabled/*;
}[/code]

Here is this vhost's config file:

[code]server {
server_name direct.powermy.biz www.powermy.biz powermy.biz;
access_log /var/log/nginx/powermybiz.access.log main;
error_log /var/log/nginx/powermybiz.error.log;

location / {
root /srv/www/powermy.biz/public_html;
index index.html index.htm index.php;
try_files $uri $uri/ /index.php?q=$uri&$args;
}

location ~ \.php$ {
root /srv/www/powermy.biz/public_html;
fastcgi_pass unix:/var/run/php-fpm/php-fpm.sock;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME /srv/www/powermy.biz/public_html/$fastcgi_script_name;
fastcgi_param PHP_ADMIN_VALUE "open_basedir=/srv/www/powermy.biz/public_html/:/srv/www/powermy.biz/logs/:/tmp/\nupload_tmp_dir=/tmp/";
fastcgi_param PHP_VALUE "allow_url_fopen=off";
include fastcgi_params;
}
}[/code]

Before you ask, yes I have tried enabling fopen in both the vhost config and my php.ini and I have restarted php-fpm and nginx after making those changes, still to no avail.

Any help is appreciated!
Subject Author Posted

NGINX and WordPress help...An Unexpected HTTP Error

sjnims November 12, 2010 12:27PM

Re: NGINX and WordPress help...An Unexpected HTTP Error

t3hslr November 14, 2010 08:14AM

Re: NGINX and WordPress help...An Unexpected HTTP Error

sjnims November 14, 2010 11:05AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 102
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready