October 30, 2010 02:52AM
On Fri, Oct 29, 2010 at 06:47:20PM -0400, Kevin wrote:

> I ran into an issue the last couple days where we noticed some files
> were being gzipped from a site (in a reverse proxy config) and others
> were not. Initially we believed it to be due to the size of the buffer
> so we increased it, enormously. Yet, no resolution.
>
> We tried buffering, caching, compression levels, vary any, proxied, etc.
> We simply couldn't find the issue. We went with a hail mary and built
> 0.8 (newest) and the issue is now resolved.
>
> Is there a bug or an issue with 0.7 and gzip in a reverse proxy config
> vs 0.8? Apparently there is something but I wanted to point out we ran
> into this issue. We can also provide configs to duplicate this problem.
>
> One last thing:
> There was not a gzip_disable string, no changes in mime.types, even
> removed all settings except gzip on;. This issue occurred with both gzip
> 1.1/1.0.

As far as I remember there should not be changes.
Could you show a debug log of non-gzipped response on 0.7 ?


--
Igor Sysoev
http://sysoev.ru/en/

_______________________________________________
nginx mailing list
nginx@nginx.org
http://nginx.org/mailman/listinfo/nginx
Subject Author Posted

GZIP Issues in 0.7 vx 0.8

Kevin October 29, 2010 06:47PM

Re: GZIP Issues in 0.7 vx 0.8

Igor Sysoev October 30, 2010 02:52AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 184
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready