Welcome! Log In Create A New Profile

Advanced

Strange cookie behavior using HttpUserIdModule

Matt Davies
October 27, 2010 07:38PM
Hey all,

I'm seeing a strange behavior using the HttpUserIdModule. I am seeing significantly more set operations that I would expect. The ratio of about 50% sets to 50% gets remains constant regardless of the days covered. So, if I include 1 day then percentage is the same as if I include several days.

The usage pattern of the clients and the sheer volume of users would indicate that we would not see 50% day after day.

So, on to specifics:

Configuration

userid on;
userid_name uid;
userid_domain xyz.com;
userid_path /;
userid_expires 365d;
userid_p3p 'policyref="/w3c/p3p.xml", CP="CUR ADM OUR NOR STA NID"';

Requests flow in from

Client -> DNS load balance -> HA load balance -> 1 of 6 nginx servers

HA load balance is HAProxy.

There are 6 identically configured servers that accept requests. We are sending the cookie as a 3rd party cookie - i.e. the cookie comes because of a javascript on zxc.com which requests something from xyz.com (our site).

I am trying to figure out if this is a user agent not respecting the cookie or something else.

Has anyone seen strange results utilizing this setup?

Thanks!

_______________________________________________
nginx mailing list
nginx@nginx.org
http://nginx.org/mailman/listinfo/nginx
Subject Author Posted

Strange cookie behavior using HttpUserIdModule

Matt Davies October 27, 2010 07:38PM

Re: Strange cookie behavior using HttpUserIdModule

mimpse August 24, 2011 09:11AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 48
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready