Welcome! Log In Create A New Profile

Advanced

Re: Unable to use multiple IPs with SSL (0.7.64)

October 20, 2010 07:52AM
On Wed, Oct 20, 2010 at 07:15:05AM -0400, danjac wrote:

> This solution works (i.e. I can restart nginx) but it doesn't recognize
> the correct domain - certificate for firstdomain.com is correct, but
> when I go to the seconddomain.com I get the SSL error "this site was
> configured for firstdomain.com" in my browser.

You see certificate for firstdomain.com for all addresse - IP2 and IP3 ?
It seems that these IP-addresses are not really configured on the host.
And the previous error "Cannot assign requested address" is related to this.

> Igor Sysoev Wrote:
> -------------------------------------------------------
> > On Wed, Oct 20, 2010 at 06:22:59AM -0400, danjac
> > wrote:
> >
> > > The IP is configured for this address, yes.
> >
> > Then something wrong in this configuration.
> > This is not nginx issue.
> > You can workaround it by binding only to *:443 and
> > letting nginx to learn
> > address at run-time:
> >
> > server {
> > listen *:443;
> > listen IP1:443;
> > }
> >
> > server {
> > listen IP2:443;
> > }
> >
> > server {
> > listen IP3:443;
> > }


--
Igor Sysoev
http://sysoev.ru/en/

_______________________________________________
nginx mailing list
nginx@nginx.org
http://nginx.org/mailman/listinfo/nginx
Subject Author Posted

Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 06:00AM

Re: Unable to use multiple IPs with SSL (0.7.64)

vesperto October 20, 2010 06:20AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 06:45AM

Re: Unable to use multiple IPs with SSL (0.7.64)

Igor Sysoev October 20, 2010 06:20AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 06:22AM

Re: Unable to use multiple IPs with SSL (0.7.64)

Igor Sysoev October 20, 2010 06:48AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 07:15AM

Re: Unable to use multiple IPs with SSL (0.7.64)

Igor Sysoev October 20, 2010 07:52AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 08:32AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 08:46AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 09:09AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 09:28AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 21, 2010 07:53AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 21, 2010 08:54AM

Re: Unable to use multiple IPs with SSL (0.7.64)

Igor Sysoev October 20, 2010 08:44AM

Re: Unable to use multiple IPs with SSL (0.7.64)

Igor Sysoev October 20, 2010 09:22AM

Re: Unable to use multiple IPs with SSL (0.7.64)

Igor Sysoev October 21, 2010 08:46AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 21, 2010 07:21PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 94
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready