Welcome! Log In Create A New Profile

Advanced

one parameter missing from GeoIP data via FCGI

August 23, 2010 09:00PM
I'm running v.0.8.49 with GeoIP using both a city and a country database. All of the GeoIP-generated parameters passed via FGCI seem to work great, except that $geoip_postal_code comes through empty.

I've checked my fastcgi_param declarations several times (my symptoms seem to point to a config issue since only one variable is impacted) but everything looks in order. MaxMind states that they don't have postal codes for all IPs, but I've tried on a few different IPs in the same general area here in the US with the same results--no postal code reported. I don't believe it's an issue on the FCGI application side, since I'm just doing a dump of the whole environment at this point.

Looking at the logfiles (debug level logging), the only thing out of order is

2010/08/23 17:39:03 [notice] 13420#0: getrlimit(RLIMIT_NOFILE): 1024:1024

which does not seem like an issue given that the number of served files will be less than 10 on this machine.

Any suggestions as to how to debug the parameter issue?
Subject Author Posted

one parameter missing from GeoIP data via FCGI

Dean August 23, 2010 09:00PM

Re: one parameter missing from GeoIP data via FCGI

Igor Sysoev August 24, 2010 02:24AM

Re: one parameter missing from GeoIP data via FCGI

Dean August 24, 2010 11:05AM

Re: one parameter missing from GeoIP data via FCGI

Igor Sysoev August 24, 2010 05:56PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 74
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready