Welcome! Log In Create A New Profile

Advanced

Fehler beim Setzen von Port

Posted by inwx 
Fehler beim Setzen von Port
February 24, 2014 07:49AM
Hallo liebe User,

ich versuche derzeit einen Webserver von Apache2 zu NGINX umzuziehen.

Ich habe alle Configs von NGINX so angepasst, dass alles auf Port "1337" hört, dennoch spuckt mir NGINX beim Starten folgendes aus:

[...]
nginx: [warn] conflicting server name "meinedomain.de" on 123.456.789.123:1337, ignored
nginx: [warn] conflicting server name "meinedomain2.de" on 123.456.789.123:1337, ignored
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] still could not bind()
nginx.


Ich finde nirgends einen Eintrag für den Port "80" bei NGINX.

Könnt ihr mir helfen? :)
Re: Fehler beim Setzen von Port
February 24, 2014 10:01AM
Ich möchte einen anderen Port nutzen, da auf Port 80 bereits ein anderer Webserver läuft.

Auszug meiner Config:

events {
worker_connections 1024;
}

http {
server_names_hash_max_size 1024;
server_names_hash_bucket_size 512;
types_hash_bucket_size 64;
types_hash_max_size 2048;
include mime.types;
keepalive_timeout 5;
keepalive_requests 100;
log_format default '$remote_addr - $remote_user $time_local "$request" $status $body_bytes_sent';
access_log /var/log/nginx/access.log;
error_log /var/log/nginx/error.log debug;
error_page 404 http://meinedomain.de/nichtvorhanden.html;

server {
listen 123.456.789.123:1337;
server_name www.meinedomain.de meinedomain.de www.meinedomain2.de meinedomain2.de
allow all;

root /www/sites/meinedomain.de/htdocs;
}
}

(Und weitere server {} - Einträge, mit gleichem Syntax für andere Domains allerdings gleiche IP-Adresse bzw. Port)
Re: Fehler beim Setzen von Port
February 25, 2014 08:29AM
Hallo,

das Problem war, dass bei einem der Server-Blöcke kein "Listen"-Parameter gegeben war, deshalb wurde der standardmäßige Port 80 versucht zu binden.

Mit "Listen 1337;" gehts nun :-)
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 74
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready