Welcome! Log In Create A New Profile

Advanced

Nginx reverse proxy then Apache then Prestashop

Posted by akaii 
Nginx reverse proxy then Apache then Prestashop
June 11, 2018 03:54PM
hello there

got in trouble with nginx as dedicated reverse proxy and dedicated apache running Prestashop.

my confs are like this :

nginx sites-available :
server {
listen 80;
server_name naru.kii.net;
return 301 https://naru.kii.net$request_uri;
}

server {
listen 443;
server_name naru.kii.net;

error_log /var/log/nginx/naru.access.log;

ssl on;
ssl_certificate /etc/nginx/ssl/kii_net/ssl-bundle.crt;
ssl_certificate_key /etc/nginx/ssl/kii_net/_kii_net.key;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;

set $upstream 192.168.1.5;

location / {
proxy_set_header X-Forwarded-Proto $scheme;
proxy_pass_header Authorization;
proxy_pass http://$upstream;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_http_version 1.1;
proxy_set_header Connection "";
proxy_buffering off;
client_max_body_size 0;
proxy_read_timeout 36000s;
proxy_redirect off;
}
}

apache sites-available :
<VirtualHost *:80>
DocumentRoot "/var/www/naru"
ServerName naru.kii.net
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
<Directory /var/www/naru/>
Options +FollowSymlinks
AllowOverride All
<IfModule mod_dav.c>
Dav off
</IfModule>
<IfModule mod_headers.c>
Header always set Strict-Transport-Security "max-age=15555000; includeSubDomains"
</IfModule>
SetEnv HOME /var/www/naru
SetEnv HTTP_HOME /var/www/naru
</Directory>
</VirtualHost>

apache sites-available ssl :
<VirtualHost *:443>
DocumentRoot "/var/www/naru"
ServerName naru.kii.net
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
<Directory /var/www/naru/>
Options +FollowSymlinks
AllowOverride All
<IfModule mod_dav.c>
Dav off
</IfModule>
<IfModule mod_headers.c>
Header always set Strict-Transport-Security "max-age=15555000; includeSubDomains"
</IfModule>
SetEnv HOME /var/www/naru
SetEnv HTTP_HOME /var/www/naru
</Directory>
</VirtualHost>

any idea that could help? I'm presently stuck
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 88
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready