414 - client sent too long URI while reading client request line for 4325 characters
September 27, 2009 12:48AM
Hello,

I have a request with 4325 characters, and am getting a 414-client sent too long URI while reading client request line error.

I have this in my server config:
client_header_buffer_size 8k;
large_client_header_buffers 4 8k;

It seems odd that it would not support 4325 characters (yes it's a little long, but would be nice if it may work).

Anyone have any suggestions?

Manish
Re: 414 - client sent too long URI while reading client request line for 4325 characters
September 27, 2009 12:03PM
It seems that ought to be adequate.

If it were me I would try:

large_client_header_buffers 8 16K;

If it works then gradually reduce the settings until you get the 414's again, so you will know the minimum needed.

--
Jim Ohlstein
Thanks Jim.

The documentation says 4 buffers of 4k or 8k. Can it support more buffers and more memory for each buffer, such as 16k and higher, if needed?

http://wiki.nginx.org/NginxHttpCoreModule

Mansih
Re: 414 - client sent too long URI while reading client request line for 4325 characters
September 27, 2009 12:58PM
Those are the default settings. You are able to modify those. In one app that I run I use:

[code]
client_header_buffer_size 2k;
large_client_header_buffers 8 12k;
[/code]

That's what I need as I also have very large requests.

--
Jim Ohlstein
Jim,

Thanks a lot... I'll give it a run.

Manish
This worked beautifully...
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 60
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready