Welcome! Log In Create A New Profile

Advanced

413 Request Entity Too Large

Posted by tjholowaychuk 
413 Request Entity Too Large
April 15, 2010 11:21AM
hey guys, I keep getting 413 Request Entity Too Large when trying to push a 6.3mb file via Curl.
I have tried the client_max_body_size directive in http {}, and in server {} at sites-enabled/default
but neither seem to work after a restart of nginx :( any ideas?

user www-data;
worker_processes 2;

error_log /var/log/nginx/error.log warn;
pid /var/run/nginx.pid;

events {
worker_connections 1024;
}

http {
client_max_body_size 8m;
client_body_buffer_size 256k;

include /etc/nginx/mime.types;
default_type application/octet-stream;
access_log /var/log/nginx/access.log;

sendfile on;
#tcp_nopush on;

#keepalive_timeout 0;
keepalive_timeout 65;
tcp_nodelay on;

gzip on;

include /etc/nginx/sites-enabled/*;

}
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 81
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready