Welcome! Log In Create A New Profile

Advanced

Upstream timed out while register on phpBB3 forum

Posted by prooi 
Upstream timed out while register on phpBB3 forum
September 12, 2009 04:21AM
Hello.

I got a problem with my Nginx server running on Debian with fastcgi.

This is the error I get:
[quote]upstream timed out (110: Connection timed out) while reading response header from upstream, client: xxx.xxx.xxx.xxx, server: main.aiondanmark.dk, request: "POST /forum/ucp.php?mode=register HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "new.aiondanmark.dk", referrer: "http://new.aiondanmark.dk/forum/ucp.php?mode=register"
[/quote]

How come?
Everything else works smoothly, just not user registration on the forums.
Any ideas how to fix this?
Im pretty sure its just a config file that has to be changed somewhere, but cant really locate it.

My nginx.conf:
[quote]
user www-data www-data;
worker_processes 1;

#error_log logs/error.log;
#error_log logs/error.log notice;
#error_log logs/error.log info;

#pid logs/nginx.pid;


events {
worker_connections 5024;
}


http {
include mime.types;
default_type application/octet-stream;

#log_format main '$remote_addr - $remote_user [$time_local] "$request" '
# '$status $body_bytes_sent "$http_referer" '
# '"$http_user_agent" "$http_x_forwarded_for"';

#access_log logs/access.log main;

sendfile on;
#tcp_nopush on;

#keepalive_timeout 0;
keepalive_timeout 65;

#gzip on;

server {
listen 80;
server_name main.aiondanmark.dk aiondanmark.dk;

#charset koi8-r;

#access_log logs/host.access.log main;

location / {
expires 30d;
error_page 404 = @joomla;
log_not_found off;
}

location @joomla {
rewrite ^(.*)$ /index.php?q=$1 last;
}

index index.php;



#error_page 404 /404.html;

# redirect server error pages to the static page /50x.html
#
#error_page 500 502 503 504 /50x.html;
#location = /50x.html {
# root html;
#}

# proxy the PHP scripts to Apache listening on 127.0.0.1:80
#
#location ~ \.php$ {
# proxy_pass http://127.0.0.1;
#}

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
#
location ~ \.php$ {
root html;
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME /usr/local/nginx/html$fastcgi_script_name;
include fastcgi_params;
}
# deny access to .htaccess files, if Apache's document root
# concurs with nginx's one
#
#location ~ /\.ht {
# deny all;
#}
}


# another virtual host using mix of IP-, name-, and port-based configuration
#
#server {
# listen 8000;
# listen somename:8080;
# server_name somename alias another.alias;

# location / {
# root html;
# index index.html index.htm;
# }
#}


# HTTPS server
#
#server {
# listen 443;
# server_name localhost;

# ssl on;
# ssl_certificate cert.pem;
# ssl_certificate_key cert.key;

# ssl_session_timeout 5m;

# ssl_protocols SSLv2 SSLv3 TLSv1;
# ssl_ciphers ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP;
# ssl_prefer_server_ciphers on;

# location / {
# root html;
# index index.html index.htm;
# }
#}

}
[/quote]

FastCGI params:
[quote]
fastcgi_param QUERY_STRING $query_string;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;

fastcgi_param SCRIPT_NAME $fastcgi_script_name;
fastcgi_param REQUEST_URI $request_uri;
fastcgi_param DOCUMENT_URI $document_uri;
fastcgi_param DOCUMENT_ROOT $document_root;
fastcgi_param SERVER_PROTOCOL $server_protocol;

fastcgi_param GATEWAY_INTERFACE CGI/1.1;
fastcgi_param SERVER_SOFTWARE AionDanmark v1.0;

fastcgi_param REMOTE_ADDR $remote_addr;
fastcgi_param REMOTE_PORT $remote_port;
fastcgi_param SERVER_ADDR $server_addr;
fastcgi_param SERVER_PORT $server_port;
fastcgi_param SERVER_NAME $server_name;

# PHP only, required if PHP was built with --enable-force-cgi-redirect
fastcgi_param REDIRECT_STATUS 200;
[/quote]

I really hope that someone can help me out of this!
Re: Upstream timed out while register on phpBB3 forum
September 12, 2009 06:38PM
Nobody able to help ?
Re: Upstream timed out while register on phpBB3 forum
September 14, 2009 12:14PM
This is your upstream taking too long to process the request.

Try adding

fastcgi_read_timeout 120;

to your configuration. The default is 60.

See http://wiki.nginx.org/NginxHttpFcgiModule#fastcgi_read_timeout.

--
Jim Ohlstein
Re: Upstream timed out while register on phpBB3 forum
September 14, 2009 03:57PM
Already tried that, but that didnt really help..

The only thing that changed was, that it didnt show up the gateway timeout, but the site still takes 1 minute and 1 second to load, which is way too much.
Re: Upstream timed out while register on phpBB3 forum
September 14, 2009 11:46PM
prooi Wrote:
-------------------------------------------------------
> Already tried that, but that didnt really help..
>
> The only thing that changed was, that it didnt
> show up the gateway timeout, but the site still
> takes 1 minute and 1 second to load, which is way
> too much.

The problem is not with nginx. Nginx can't serve the content until the upstream has responded. It's the upstream (PHP) taking a long time to process the script (more likely it's a poorly written script). The gateway timeouts were a symptom of just that. The fact that the page loads "correctly" when you lengthen the timeout is proof.

--
Jim Ohlstein
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 78
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready