Welcome! Log In Create A New Profile


I am in big trouble

Posted by paaru.linux 
I am in big trouble
August 21, 2009 02:31AM
Friends i am a newbie in this nginx world

My problem is that, My company is now launching a new website and expecting 4lacs hits per second.

From googling and googling I found nginx would be a better solution
we have two production servers with good configuration
our setup is that nginx + ruby + passenger

i have configured nginx on a local server and after 200 concurrent hits the site is too busy.... hmmm....

help me to solve my issue...
waiting for ur replies

Advancedthanks to all...
Re: I am in big trouble
August 23, 2009 07:00AM
Are you sure that nginx is the problem?

Could you provide your nginx configuration and maybe some log entries which explain the problem?

Re: I am in big trouble
August 24, 2009 04:23AM
I would recommend you, to get a real administrator for the server. You as a noob can't really handle this kind of problems. I don't think that nginx is the problem right now. ;)


Sites using nginx: http://www.pcmasters.de/ && http://xbox.pcmasters.de/

Edited 1 time(s). Last edit at 08/24/2009 04:24AM by compiler.
Re: I am in big trouble
August 26, 2009 03:41PM
But as everyone else he should get his chance to learn how things work. Your answer isn't helping anyone.

Re: I am in big trouble
August 31, 2009 01:34AM
thx for ur reply
here i am showing my nginx config.
pls help me to solve my issue...

user nginx;
worker_processes 10;

#error_log logs/error.log;
#error_log logs/error.log notice;
#error_log logs/error.log info;

#pid logs/nginx.pid;

events {
worker_connections 20000;

http {
passenger_root /usr/local/lib/ruby-ent/lib/ruby/gems/1.8/gems/passenger-2.2.4;
passenger_ruby /usr/local/lib/ruby-ent/bin/ruby;

include mime.types;
default_type application/octet-stream;
sendfile on;
#tcp_nopush on;

#keepalive_timeout 0;
keepalive_timeout 65;

gzip on;
gzip_buffers 16 8k;
gzip_comp_level 9;
gzip_min_length 0;
gzip_types text/plain text/css image/x-icon image/bmp image/jpg image/gif image/png;
gzip_vary on;

server {
listen 80;
server_name example.com;
passenger_enabled on;

#charset koi8-r;

#access_log logs/host.access.log main;

root /var/www/html/example.com/public;
# location / {
# index index.html index.htm;
# }

location /nginx_status {
stub_status on;
access_log off;
allow all;

error_page 500 502 503 504 /50x.html;
location = /50x.html {
root html;

## Stop Image and Document Hijacking
location ~* (\.jpg|\.png|\.css)$ {
if ($http_referer !~ ^(http://example.com) ) {
return 444;

Edited 1 time(s). Last edit at 08/31/2009 01:34AM by paaru.linux.
Re: I am in big trouble
August 31, 2009 01:38AM
Can anyone give ur email id for online help?
that would help me very much?
its three days remaining for me...
Re: I am in big trouble
September 05, 2009 04:17AM
The first thing that pops out of your config is the extremly high value for worker_connections, 20000 is far too much. A value like 1024 or 2048 is enough. Also the worker_processes is too high, the value should be the same as the count of your CPU cores. By setting the correct values for this two options your problem could be solved.

Re: I am in big trouble
September 07, 2009 08:19AM
Thx buddy,

I have changed that two values to 2 and 2048 but still getting the same problem.
what can I do?
Top levels members may throw me out... hmmm....
Re: I am in big trouble
September 11, 2009 10:45PM
Nobody is here to help me??
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 60
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready