Welcome! Log In Create A New Profile


SSL on Hostinger Ubuntu and LiteCart

Posted by HerrimanCoder 
SSL on Hostinger Ubuntu and LiteCart
May 01, 2024 08:45AM
I'm trying to run LiteCart on Ubuntu, on Hostinger. Everything works except that the SSL cert is being seen as invalid. Normally when I set up a website and link it to a new domain via CloudPanel on Ubuntu/Hostinger, the Let's Encrypt cert (auto-installed) begins working immediately and perfectly. But in this case it's a subdomain: store.sweetdezibakes.com. All browsers see it as an invalid cert and give the dire warnings. Here are my vhost nginx settings at the OS-level:

server {
listen 80;
listen [::]:80;
listen 443 ssl http2;
listen [::]:443 ssl http2;
server_name store.sweetdezibakes.com;


if ($scheme != "https") {
rewrite ^ https://$host$uri permanent;

location ~ /.well-known {
auth_basic off;
allow all;


location / {
proxy_set_header Host $http_host;
proxy_set_header X-Forwarded-Host $http_host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_hide_header X-Varnish;
proxy_redirect off;
proxy_max_temp_file_size 0;
proxy_connect_timeout 720;
proxy_send_timeout 720;
proxy_read_timeout 720;
proxy_buffer_size 128k;
proxy_buffers 4 256k;
proxy_busy_buffers_size 256k;
proxy_temp_file_write_size 256k;

location ~* ^.+\.(css|js|jpg|jpeg|gif|png|ico|gz|svg|svgz|ttf|otf|woff|woff2|eot|mp4|ogg|ogv|webm|webp|zip|swf|map)$ {
add_header Access-Control-Allow-Origin "*";
expires max;
access_log off;

if (-f $request_filename) {

server {
listen 8080;
listen [::]:8080;
server_name store.sweetdezibakes.com;

try_files $uri $uri/ /index.php?$args;
index index.php index.html;

location ~ \.php$ {
include fastcgi_params;
fastcgi_intercept_errors on;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
try_files $uri =404;
fastcgi_read_timeout 3600;
fastcgi_send_timeout 3600;
fastcgi_param HTTPS "on";
fastcgi_param SERVER_PORT 443;
fastcgi_param PHP_VALUE "{{php_settings}}";

if (-f $request_filename) {

And here are the settings in my LiteCart .conf file (inside vhost folder) that LiteCart told me to use:

server {
server_name store.sweetdezibakes.com;
# listen 80;

listen 443 ssl;
ssl_certificate /etc/ssl/certs/domainname-ssl-bundle.crt;
ssl_certificate_key /etc/ssl/private/domainname.key;

root "/";
index index.php index.html index.htm;

location / {
rewrite ^/(cache|images)/ /$request_uri last;
try_files $uri $uri/ /index.php$is_args$args;

location ~ .php$ {
include conf/fastcgi_params;

#fastcgi_pass unix:/run/php/php8.1-fpm.sock;

fastcgi_param REDIRECT_HTTP_MOD_REWRITE On; # Enables LiteCart's URL rewriting

location ~ .(a?png|bmp|css|eot|gif|ico|jpe?g|jp2|js|otf|pdf|svg|tiff?|ttf|webp|woff2?)$ {
expires 2w;
gzip_static on;

location ~ .(htaccess|htpasswd|inc.php)$ {
deny all;

location ~ ^/(data|logs|vendor|vmods|vqmod)/ {
deny all;

The paths to the .crt and .key do not exist, and Hostinger support tells me that I don't have access to those files, they're all taken care of by the OS. I understand why they say that: normally the certs are automatic and just work. But when I'm getting cert errors and LiteCart is telling me to use this special .conf file in a vhost folder...I'm mystified at this point.

Any ideas?
Re: SSL on Hostinger Ubuntu and LiteCart
May 01, 2024 09:21AM
Apologies everyone - it was just a bad cert, I had to re-create it, then all was well.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 179
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 500 on July 15, 2024
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready