Welcome! Log In Create A New Profile

Advanced

Can't Add Certs

Posted by SkipMorrow 
Can't Add Certs
November 09, 2022 12:41PM
I get an error when I try to add a cert to nginx. When I test server reachability, I always get this error immidately: Communication with the API failed, is NPM running correctly?

(gist available here: https://gist.github.com/MrGibbage/249c2b5a08a1791842c8db7c3082c9dd)

I installed nginx with the docker-compose available in the gist

There are no errors in the log when I start it up. I even rebuilt the container, same thing happens. When I do the test, logged errors are in the gist linked above.

But when I go to site24x7.com, and check my domain, it works fine. It shows the correct IP addresses from all countries. Using Cloudfare, un-proxied DNS. One "A" record that points to my IP address.

Finally, I have questions about what ports I should forward on my router. As I type this post, my current settings are forwarding both 80 and 443 to my NAS (192.168.0.2) on the same ports, 80 & 443. But to access my nginx admin panel, I go to 192.168.0.2:8881. I have tried forwarding incoming traffic on ports 80 and 443 to 8880, 8881, and 4443 (from the docker-compose), but I still get that same API failed error.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 72
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready