Welcome! Log In Create A New Profile


Cannot push rtmp to Vimeo or Microsoft

Posted by happy8 
Cannot push rtmp to Vimeo or Microsoft
July 30, 2020 06:48AM

In short im trying to use NGINX to push a rtmp stream to Microsoft Office and Vimeo for a live event .
The setup is as follows:
OBS to encode on a PC
Streams to NGINX server
NGINX server push to Vimeo and Microsoft
Streaming works fine on the local network and direct from OBS to both destinations but not when I push it through NGINX.

Copy of conf file below

user nginx;
worker_processes auto;

error_log /var/log/nginx/error.log notice;
pid /var/run/nginx.pid;

load_module modules/ngx_rtmp_module.so;

events {
worker_connections 1024;

rtmp {
server {
listen 1935;
application live {
live on;
interleave on;
#hls on;
#hls_path /tmp/hls;
#hls_fragment 15s;
#dash on;
#dash_path /tmp/dash;
#dash_fragment 15s;
record off;
# push to Vimeo
push rtmp://rtmp-global.cloud.vimeo.com/live/fdb0aXXXXXXXXXXXX339924cb4ac2;
# push to Microsoft Live Event
push rtmp://kebnu7wpt7uceeshq6mgh6z2ma-streamaase1su011-aase.channel.media.azure.net:1935


# video on demand for saved content
application vod {
play /var/vod;

http {
include /etc/nginx/mime.types;
default_type application/octet-stream;

log_format main '$remote_addr - $remote_user [$time_local] "$request" '
'$status $body_bytes_sent "$http_referer" '
'"$http_user_agent" "$http_x_forwarded_for"';

access_log /var/log/nginx/access.log main;

sendfile on;
#tcp_nopush on;

keepalive_timeout 65;

#gzip on;

include /etc/nginx/conf.d/*.conf;

# TCP/UDP proxy and load balancing block
#stream {
# Example configuration for TCP load balancing

#upstream stream_backend {
# zone tcp_servers 64k;
# server backend1.example.com:12345;
# server backend2.example.com:12345;

#server {
# listen 12345;
# status_zone tcp_server;
# proxy_pass stream_backend;

Any assistance apreciated
Re: Cannot push rtmp to Vimeo or Microsoft
July 30, 2020 09:26AM
Some further news. I worked out the the company firewall was blocking the broadcast . Edited the rules and inspection policies to exclude and allow all traffic from the NGINX server and now Vimeo works okay.

Microsoft Streams still does not work ie it never connects. In the firewall I can see constant connections and disconnections to the Microsoft host on ports 1935 but no video ever appears

Just a note the article quoted here https://techcommunity.microsoft.com/t5/microsoft-stream-forum/unable-to-use-nginx-rtmp-streaming-server-with-stream/m-p/1276682

says the correct way to push to Streams is to use the app= after push which I have done but still no luck eg

push rtmp://kebnu7wpt7uceeshq6mgh6z2ma-streamaase1su011-aase.channel.media.azure.net:1935 app=live/app568faf35XXXXXXXXXXXX2bffd6f77;
Re: Cannot push rtmp to Vimeo or Microsoft
August 02, 2020 06:39PM
Found this article which is exactly the issue Im having with Microsoft Live streaming and NGINX


It seems that there is something that MS does if the stream is relayed through NGINX. unfortuntley the sytnax using the push command with the app switch makes no difference in my case ie

push rtmp://kebnu7wpt7uceeshq6mgh6z2ma-streamaase1su011-aase.channel.media.azure.net:1935 app=live/app568faf35XXXXXXXXXXXX2bffd6f77;
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 92
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready