Welcome! Log In Create A New Profile

Advanced

compiling for Raspbian Buster

Posted by petter5 
compiling for Raspbian Buster
December 29, 2019 07:12AM
Running Raspbian Buster, as for today 29 december 2019, version of nginx is version: nginx/1.14.2 when installed from Raspbian repositories, latest release is nginx 1.17.7.
So I want to compile latest version, and also add support for brotli.

When doing nginx -V on the current installed nginx on the raspberrypi 4 (4gb) I get:

nginx version: nginx/1.14.2
built with OpenSSL 1.1.1c 28 May 2019 (running with OpenSSL 1.1.1d 10 Sep 2019)
TLS SNI support enabled
configure arguments: --with-cc-opt='-g -O2 -fdebug-prefix-map=/build/nginx-7du1qr/nginx-1.14.2=. -fstack-protector-strong -Wformat -Werror=format-security -fPIC -Wdate-time -D_FORTIFY_SOURCE=2' --with-ld-opt='-Wl,-z,relro -Wl,-z,now -fPIC' --prefix=/usr/share/nginx --conf-path=/etc/nginx/nginx.conf --http-log-path=/var/log/nginx/access.log --error-log-path=/var/log/nginx/error.log --lock-path=/var/lock/nginx.lock --pid-path=/run/nginx.pid --modules-path=/usr/lib/nginx/modules --http-client-body-temp-path=/var/lib/nginx/body --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-proxy-temp-path=/var/lib/nginx/proxy --http-scgi-temp-path=/var/lib/nginx/scgi --http-uwsgi-temp-path=/var/lib/nginx/uwsgi --with-debug --with-pcre-jit --with-http_ssl_module --with-http_stub_status_module --with-http_realip_module --with-http_auth_request_module --with-http_v2_module --with-http_dav_module --with-http_slice_module --with-threads --with-http_addition_module --with-http_geoip_module=dynamic --with-http_gunzip_module --with-http_gzip_static_module --with-http_image_filter_module=dynamic --with-http_sub_module --with-http_xslt_module=dynamic --with-stream=dynamic --with-stream_ssl_module --with-stream_ssl_preread_module --with-mail=dynamic --with-mail_ssl_module --add-dynamic-module=/build/nginx-7du1qr/nginx-1.14.2/debian/modules/http-auth-pam --add-dynamic-module=/build/nginx-7du1qr/nginx-1.14.2/debian/modules/http-dav-ext --add-dynamic-module=/build/nginx-7du1qr/nginx-1.14.2/debian/modules/http-echo --add-dynamic-module=/build/nginx-7du1qr/nginx-1.14.2/debian/modules/http-upstream-fair --add-dynamic-module=/build/nginx-7du1qr/nginx-1.14.2/debian/modules/http-subs-filter

From the compiler arguments I can see that a lot of modules is located in /build/nginx-7du1qr/nginx-1.14.2/debian/modules witch reefers to nginx 1.14.2 and the local build directory where the Raspbian nginx package was built.

My goal is to use latest nginx version, compiled with the Raspbian style of paths like --conf-path=/etc/nginx/nginx.conf --http-log-path=/var/log/nginx/access.log --error-log-path=/var/log/nginx/error.log --lock-path=/var/lock/nginx.lock --pid-path=/run/nginx.pid etc.
Since I will use this build to test Thirtybees on a Raspberrypi4 with 4 gig ram, I will also need all nginx modules to run Thrtybees safe under nginx on the raspberry.

I want as minimum nginx modules ( compiler arguments to be used) required to use for nginx to support :
* http2
* Certbot on Raspbian Buster for obtaining Let’s Encrypt
* brotli
* etc etc
To simplify my question: is there any compiler arguments that can safely be removed form the nginx -V list above and is there any other that is recommended to add (except for --brotli) when compiling nginx to be used for a sage installation to be used for Thirtybees running under Raspbian buster
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 70
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready