Welcome! Log In Create A New Profile

Advanced

Nginx not serving images from Windows app

Posted by snipes 
Nginx not serving images from Windows app
July 08, 2019 12:22PM
Hi,

Let me start by saying I am very new to all of this, so please excuse my lack of knowledge.

I have Nginx running on ubuntu. I am using the reverse proxy feature to serve up web apps that run on different ports on my windows server. I am having an issue with images not being served. When a user goes to the domain, the page loads, but all images are gone. Here is the error message from the nginx log:
2019/07/08 10:50:20 [crit] 29174#29174: *5662 open() "/var/lib/nginx/proxy/2/80/0000001802" failed (13: Permission denied) while reading upstream, client: 174.226.9.250, server: mysub.mydomain.net, request: "GET /444348088AC3FC45BA2BB94B5092E514F715451C/styles.css HTTP/1.1", upstream: "http://192.168.1.50:8008/444348088AC3FC45BA2BB94B5092E514F715451C/styles.css", host: "mysub.mydomain.net", referrer: "https://mysub.mydomain.net/"

I have attached copies of the conf files. I had some help writing the conf files, however the person that helped me is stumped as well.

Thanks
Attachments:
open | download - mysub.mydomain.conf.txt (3.9 KB)
open | download - nginx.conf.txt (3.6 KB)
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 70
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready