Welcome! Log In Create A New Profile

Advanced

weird 403

Posted by giorg 
weird 403
January 17, 2019 06:07AM
hello,
I have a wamp net setup with nginx and laravel, dev environment. Until yesterday everything was working fine. Then I had to do git pull as my colleague did push some new features, after that basic installation of laravel is still working fine, but when I request a particular url as:

http://mysite/games/mygame

nginx throws a 403, treating that as folder, when it should not. I did not change nginx conf from yesterday, so I really dont understand, until yesterday that url was working just fine.

This is my conf:

server
{
listen 127.0.0.1:80;
error_log C:\wamp.net-1.1.1\bin\1-nginx_1.13.1_x86\logs\error.log emerg;
server_name "setonline.test";
root "C:/wamp.net-1.1.1/sites/setonline/public/";
location /
{
try_files $uri $uri/ /index.php?$args;
}
location ~ \.php$
{
fastcgi_pass 127.0.0.1:728;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
}
}

server
{
listen 127.0.0.1:443 ssl;
server_name "setonline.test";
root "C:/wamp.net-1.1.1/sites/setonline/public/";
ssl_certificate "C:/wamp.net-1.1.1/bin/1-nginx_1.13.1_x86/conf/vhosts/setonline.test.crt";
ssl_certificate_key "C:/wamp.net-1.1.1/bin/1-nginx_1.13.1_x86/conf/vhosts/setonline.test.key";
ssl_session_cache shared:SSL:1m;
ssl_session_timeout 5m;
ssl_ciphers HIGH:!aNULL:!MD5;
ssl_prefer_server_ciphers on;
location /
{
try_files $uri $uri/ /index.php?$args;
}
location ~ \.php$
{
fastcgi_pass 127.0.0.1:728;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
}
}

any suggestion?
thanks a lot
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 72
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready