Welcome! Log In Create A New Profile

Advanced

Proper syntax in nginx.conf

Posted by matrixebiz 
Proper syntax in nginx.conf
February 07, 2018 01:57PM
Hello, running Nginx for Windows but when I run it and then try to ping the server I get pinging replys but 504 server errors and cant get the index page to load. Do I have something wrong in my config file below?


location / {
# root html;
root C:/www/htdocs;
index C:/www/htdocs/index.html;
}



Edited 1 time(s). Last edit at 02/07/2018 02:02PM by matrixebiz.
Re: Proper syntax in nginx.conf
February 07, 2018 02:22PM
Sorry, the ping error is 500 Internal server error
Re: Proper syntax in nginx.conf
February 07, 2018 02:38PM
okay, I changed it to

root C:/www/htdocs;
index.php index.html index.htm;

I don't get the error now and it pings correctly but unable to resolve the domain name. is there something else I have to change to make is actually serve webpages and files?


If I go to localhost from the machine it is fine but not able to resolve site externally



Edited 1 time(s). Last edit at 02/07/2018 02:45PM by matrixebiz.
Re: Proper syntax in nginx.conf
February 08, 2018 10:35PM
Solved - I didn't enable Nginx in the Windows Firewall
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 184
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready