Welcome! Log In Create A New Profile

Advanced

Issue with $fastcgi_param

Posted by Sendarolo 
Issue with $fastcgi_param
August 03, 2016 05:51AM
Running Windows + Nginx 1.11.3.1 + PHP 5.6.10

I have a strange issue with $fastcgi_param
probably this issue it depends on PHP, but i wanted some advice.

when set Nginx with similar conf:

location ~ \.php$ {

include fastcgi_params;
fastcgi_pass myLoadBalancer;
#fastcgi_param PHP_ADMIN_VALUE "memory_limit = 16M";
fastcgi_param PHP_VALUE "open_basedir = \"C:/mysite1/wwroot/\"";
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME C:/mysite1/wwroot/$fastcgi_script_name;
fastcgi_param ENVIRONMENT production;
fastcgi_buffer_size 128k;
fastcgi_buffers 256 16k;
fastcgi_busy_buffers_size 256k;
fastcgi_temp_file_write_size 256k;


}

the _SERVER["PHP_VALUE"] open_basedir = "C:/mysite1/wwroot/"
appears correctly in Evironment variables in phpinfo() but every script have access in other folder in the server

this problem appears in only value passed with PHP_ADMIN_VALUE or PHP_VALUE
example fastcgi_param PHP_ADMIN_VALUE "memory_limit = 16M"; disabled in previeus conf

any idea? :/
Re: Issue with $fastcgi_param
August 03, 2016 07:03AM
It looks like this is not (yet) supported, see https://www.google.nl/#q=fastcgi+param+php_value+open_basedir
ea. https://github.com/facebook/hhvm/issues/3730

---
nginx for Windows http://nginx-win.ecsds.eu/
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 95
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready