Welcome! Log In Create A New Profile

Advanced

Nginx on PC with win-xp and php

Posted by kflee2000 
Nginx on PC with win-xp and php
December 12, 2011 04:30AM
The problem is Nginx (1.1.10) does not seem to respond to a php file. Any suggestion welcomed.

1. XP with IIS + PHP + FastyCGI --- this has been installed and work fine Type 127.0.0.1 would get what it should be.

2. Nginx installed specified port 8888 and this is also work fine. Typing 127.0.0.1:8888 which will show the content of html/index.html.

3. The PHP section is un-commented as follow:

location ~ \.php$ {
root html;
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME /scripts$fastcgi_script_name;
include fastcgi_params;
}

The 127.0.0.1:8888/index.php or 127.0.0.1:9000/index.php only produce page unavailable message.

3.1 Test adding listen 9000 -- make no difference
3.2 Test with the following -- make no difference
fastcgi_param SCRIPT_FILENAME "C:\WINDOWS\system32\inetsrv\fcgiext.dll";
fastcgi_param SCRIPT_FILENAME "C:\Program Files\PHP\php.exe";

The questions are:

1. is it right to think the correct testing should be: 127.0.0.1.8888/index.php and Nginx would know to direct PHP extention to fastcgi.dll?

2. I can not see anywhere in nginx.conf file tell Nginx to use fastcgi.dll? I thought it should be the SCRIPT_FILENAME variable
but testing with both does not seem to make any difference?

3. Is it necessary to have IIS enabled? I thought it should not but can not be sure.

Best regards,
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 102
Record Number of Users: 7 on March 06, 2014
Record Number of Guests: 229 on August 01, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready