Welcome! Log In Create A New Profile

Advanced

[alert] 12928#0: worker process 3958 exited on signal 11

June 04, 2014 03:29PM
I use nginx 1.7.1 as frontend proxy to Apache 2.2.27 + php-fpm 5.5.13.

When I add new domain, then just reload nginx it throwing errors like "connection reset" etc.

Error log is full of something like this:

tail -f /var/log/nginx/error.log
2014/06/04 11:36:23 [alert] 12928#0: worker process 3958 exited on signal 11
2014/06/04 11:36:23 [alert] 12928#0: worker process 3959 exited on signal 11
2014/06/04 11:36:23 [alert] 12928#0: worker process 3992 exited on signal 11
2014/06/04 11:36:23 [alert] 12928#0: worker process 3982 exited on signal 11
2014/06/04 11:36:24 [alert] 12928#0: worker process 3993 exited on signal 11
2014/06/04 11:36:24 [alert] 12928#0: worker process 3995 exited on signal 11
2014/06/04 11:36:25 [alert] 12928#0: worker process 4001 exited on signal 11
2014/06/04 11:36:25 [alert] 12928#0: worker process 3994 exited on signal 11
2014/06/04 11:36:25 [alert] 12928#0: worker process 4002 exited on signal 11
2014/06/04 11:36:26 [alert] 12928#0: worker process 4021 exited on signal 11

Then I have to restart nginx, and sometimes even killall -9 nginx then restart, because then it shows something like this:

2014/06/04 21:16:30 [emerg] 11491#0: bind() to 0.0.0.0:443 failed (98: Address already in use)
2014/06/04 21:16:30 [emerg] 11491#0: bind() to [::]:443 failed (98: Address already in use)
2014/06/04 21:16:35 [emerg] 11754#0: bind() to 0.0.0.0:80 failed (98: Address already in use)
2014/06/04 21:16:35 [emerg] 11754#0: bind() to [::]:80 failed (98: Address already in use)
2014/06/04 21:16:35 [emerg] 11754#0: bind() to 0.0.0.0:443 failed (98: Address already in use)
2014/06/04 21:16:35 [emerg] 11754#0: bind() to [::]:443 failed (98: Address already in use)
2014/06/04 21:16:35 [emerg] 11754#0: bind() to 0.0.0.0:80 failed (98: Address already in use)
2014/06/04 21:16:35 [emerg] 11754#0: bind() to [::]:80 failed (98: Address already in use)
2014/06/04 21:16:35 [emerg] 11754#0: bind() to 0.0.0.0:443 failed (98: Address already in use)
2014/06/04 21:16:35 [emerg] 11754#0: bind() to [::]:443 failed (98: Address already in use)

How to resolve this ?

My config is as follows:

user nginx;

worker_processes 8;
worker_rlimit_nofile 400000;

pid /var/run/nginx.pid;

events {
worker_connections 8192;

use epoll;
}


http {
add_header Cache-Control public;

server_names_hash_max_size 4096;
server_names_hash_bucket_size 2048;

types_hash_bucket_size 64;
types_hash_max_size 2048;

client_header_buffer_size 2k;
client_header_timeout 180s;
client_body_timeout 180s;
send_timeout 180s;

client_max_body_size 64M;
client_body_buffer_size 128k;

sendfile on;
tcp_nopush on;
tcp_nodelay on;
server_tokens off;

include '/etc/nginx/conf.d/*.conf';
}

include /etc/nginx/mime.types;

default_type application/octet-stream;

log_format main '$remote_addr - $remote_user [$time_local] "$request" '
'$status $body_bytes_sent "$http_referer" '
'"$http_user_agent" "$http_x_forwarded_for"';

#access_log /var/log/nginx/access.log main;
error_log /var/log/nginx/error.log alert;

### MR - must be using nginx-special (including ngx_http_log_request_speed)
## just enough remove # below for enable; only request > 5000 miliseconds write to error.log
#log_request_speed_filter on;
#log_request_speed_filter_timeout 5000;

gzip on;
gzip_static on;
gzip_min_length 1024;
gzip_comp_level 4;
gzip_proxied any;

gzip_types text/plain
text/css
application/x-javascript
text/xml
application/xml
application/xml+rss
text/javascript;

keepalive_timeout 180;

limit_conn_zone $binary_remote_addr zone=addr:10m;
limit_rate_after 1000m;
limit_rate 12500k;

proxy_cache_path /dev/shm/nginx-proxy levels=1:2 keys_zone=pcache:8m max_size=1000m inactive=600m;
proxy_temp_path /dev/shm/nginx 1 2;

fastcgi_cache_path /dev/shm/nginx-fastcgi levels=1:2 keys_zone=fcache:8m max_size=1000m inactive=600m;
fastcgi_temp_path /dev/shm/nginx 1 2;

include /home/nginx/conf/defaults/*.conf;
include /home/nginx/conf/domains/*.conf;

Example domain config:

### begin - web of 'vmax24.pl' - do not remove/modify this line


## webmail for 'vmax24.pl'
server {
#disable_symlinks if_not_owner;

listen 0.0.0.0:80;
listen [::]:80;

server_name webmail.vmax24.pl;

index index.php index.html index.shtml index.htm default.htm Default.aspx Default.asp index.pl;

set $rootdir '/home/kloxo/httpd/webmail/onlinemail';

root $rootdir;

include '/home/nginx/conf/globals/custom.proxy.conf';
}


## web for 'vmax24.pl'
server {
#disable_symlinks if_not_owner;

listen 0.0.0.0:80;
listen [::]:80;

server_name vmax24.pl www.vmax24.pl;

index index.php index.html index.shtml index.htm default.htm Default.aspx Default.asp index.pl;

set $domain 'vmax24.pl';

set $rootdir '/home/eremi21/vmax24.pl';

root $rootdir;

set $user 'eremi21';

set $fpmport '57907';

include '/home/nginx/conf/globals/custom.proxy.conf';

include '/home/nginx/conf/globals/generic.conf';
}


## webmail for 'vmax24.pl'
server {
#disable_symlinks if_not_owner;

listen 0.0.0.0:443;
listen [::]:443;

ssl on;
ssl_certificate /home/kloxo/httpd/ssl/eth0___localhost.pem;
ssl_certificate_key /home/kloxo/httpd/ssl/eth0___localhost.key;
ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2;
ssl_ciphers HIGH:!aNULL:!MD5;

server_name webmail.vmax24.pl;

index index.php index.html index.shtml index.htm default.htm Default.aspx Default.asp index.pl;

set $rootdir '/home/kloxo/httpd/webmail/onlinemail';

root $rootdir;

include '/home/nginx/conf/globals/custom.proxy.conf';
}


## web for 'vmax24.pl'
server {
#disable_symlinks if_not_owner;

listen 0.0.0.0:443;
listen [::]:443;

ssl on;
ssl_certificate /home/kloxo/httpd/ssl/eth0___localhost.pem;
ssl_certificate_key /home/kloxo/httpd/ssl/eth0___localhost.key;
ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2;
ssl_ciphers HIGH:!aNULL:!MD5;

server_name vmax24.pl www.vmax24.pl;

index index.php index.html index.shtml index.htm default.htm Default.aspx Default.asp index.pl;

set $domain 'vmax24.pl';

set $rootdir '/home/eremi21/vmax24.pl';

root $rootdir;

set $user 'eremi21';

set $fpmport '57907';

include '/home/nginx/conf/globals/custom.proxy.conf';

include '/home/nginx/conf/globals/generic.conf';
}


### end - web of 'vmax24.pl' - do not remove/modify this line
SubjectAuthorPosted

[alert] 12928#0: worker process 3958 exited on signal 11

SpacedustJune 04, 2014 03:29PM

Re: [alert] 12928#0: worker process 3958 exited on signal 11

SpacedustJune 04, 2014 03:30PM

Re: [alert] 12928#0: worker process 3958 exited on signal 11

Piotr SikoraJune 04, 2014 03:48PM

Re: [alert] 12928#0: worker process 3958 exited on signal 11

SpacedustJune 04, 2014 03:53PM

Re: [alert] 12928#0: worker process 3958 exited on signal 11

Homutov VladimirJune 04, 2014 03:50PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 110
Record Number of Users: 7 on March 06, 2014
Record Number of Guests: 229 on August 01, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready