Welcome! Log In Create A New Profile

Advanced

Re: proxy_store help requested

March 09, 2014 10:34PM
The 304 response from the upstream server ended up being the culprit. If I changed the upstream server to have 'if_modified_since off;" and thus always respond with a 200 and the content, the problem is resolved. To freshen the mirror, I can then simply remove the mirrored content from the downstream server; no nginx processes even need to be restarted.

Maxim, this may be obvious to you, but it wasn't to me, and no documentation pointed me in this direction. As a suggestion, a small note about the significance of setting i-m-s off on upstream servers in such mirroring situations in the documentation about proxy_store would be helpful.

As always, I'm extremely grateful for your work, and for the others that provide this awesome software.
SubjectAuthorPosted

proxy_store help requested

nginx_newbie_tooMarch 08, 2014 05:39PM

Re: proxy_store help requested

nginx_newbie_tooMarch 08, 2014 05:45PM

Re: proxy_store help requested

nginx_newbie_tooMarch 08, 2014 06:21PM

Re: proxy_store help requested

Maxim DouninMarch 08, 2014 07:16PM

Re: proxy_store help requested

nginx_newbie_tooMarch 08, 2014 08:51PM

Re: proxy_store help requested

nginx_newbie_tooMarch 09, 2014 10:34PM

Re: proxy_store help requested

Maxim DouninMarch 10, 2014 07:08PM

Re: proxy_store help requested

nginx_newbie_tooMarch 11, 2014 12:46PM

Re: proxy_store help requested

Maxim DouninMarch 12, 2014 07:50AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 61
Record Number of Users: 7 on March 06, 2014
Record Number of Guests: 229 on August 01, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready