Welcome! Log In Create A New Profile

Advanced

Nginx internal server errors static files first load only?

July 30, 2013 03:17PM
Hi Guys,

Got a strange issue happening, I do my coding on Windows 8 x64 using Sublime Text 2.0.2, my sites run of a Ubuntu 13.04 VirtualBox guest over a bridged adaptor connection.

Weird thing happens, if I save a static file (HTML, CSS etc) from Sublime on Windows to my Ubuntu vm and load it I get a 500 internal error (generic nginx one), hit refresh and all is well. However, If I do the same from Notepad++ I get no issues at all, the file will load first time on nginx.

Both are set for EOL unix and UTF-8 and even changing this on both seems to bring the same issue? The nginx error log is vague, just saying its temporarily unavailable.

I've posted this on the sublime forum too, as it seems to be sumin that is doing with the file upon saving? Even saving a .html in plain old notepad is fine.

Does anyone have any ideas what this could be? How I can solve it? Or even find out more info on why nginx does like the file first time round?

Also worth mentioning that no such issue occurs with Apache, that serves all files?

Any help appreciated!

Thanks
SubjectAuthorPosted

Nginx internal server errors static files first load only?

keoghJuly 30, 2013 03:17PM

Re: Nginx internal server errors static files first load only?

keoghJuly 30, 2013 03:20PM

Re: Nginx internal server errors static files first load only?

keoghJuly 30, 2013 05:26PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 75
Record Number of Users: 7 on March 06, 2014
Record Number of Guests: 229 on August 01, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready