Welcome! Log In Create A New Profile

Advanced

Re: Disable open_file_cache for a specific location

July 08, 2013 03:42PM
Okay:

This is the demo gallery of the gallery plugin I (want to) use: http://wp.oopstouch.com/?page_id=22

As you can see the first thumbnail pictures are thumbnails for different albums. When you click on one of them the album will be opened and then you can click on a thumbnail picture again to open it in fullscreen.

If you compare that with my gallery (which worked before with Apache) here: http://www.peleke.de/galerie/google/
Nothing happens after a click on an album thumbnail. You will only see a reload of the page and this added to the URL: ?page_id=0&albid=5898003541337462625 (for example) which should show the thumbnail pictures of the album.

Maybe it is just a simple URL problem (that was solved in a .htaccess file with Apache before) or expires js problem!?
I am no expert and would be happy if you could help me, thanks!

Different nginx conf files:

sendfile on;
tcp_nopush on;
tcp_nodelay on;

types_hash_max_size 2048;

send_timeout 2;

client_max_body_size 20m;
client_body_buffer_size 128k;
client_body_timeout 10;
client_header_timeout 10;
keepalive_timeout 10;

open_file_cache max=5000 inactive=20s;
open_file_cache_valid 30s;
open_file_cache_min_uses 2;
open_file_cache_errors on;

gzip on;
gzip_http_version 1.1;
gzip_vary on;
gzip_comp_level 6;
gzip_proxied any;
gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript application/javascript text/x-js;
gzip_buffers 16 8k;
gzip_disable "MSIE [1-6]\.(?!.*SV1)"

location ~* ^.+.(jpg|jpeg|gif|css|js|png|ico|html|xml|txt)$ {
access_log off;
expires modified max;
}

location ~ /\.ht {
deny all;
}

fastcgi_split_path_info ^(.+\.php)(/.+)$;

location / {
try_files $uri $uri/ /index.php;
#include /etc/nginx/proxy_params;
}

location ~ \.php$ {
#limit_req zone=limit burst=5 nodelay;
try_files $uri =404;
#fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_intercept_errors off;
fastcgi_read_timeout 120;
fastcgi_buffers 256 4k;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
include /etc/nginx/fastcgi_params;
}
SubjectAuthorPosted

Disable open_file_cache for a specific location

PelekeJuly 02, 2013 05:24PM

Re: Disable open_file_cache for a specific location

Francis DalyJuly 02, 2013 05:44PM

Re: Disable open_file_cache for a specific location

PelekeJuly 02, 2013 05:56PM

Re: Disable open_file_cache for a specific location

Francis DalyJuly 03, 2013 03:56AM

Re: Disable open_file_cache for a specific location

PelekeJuly 03, 2013 08:00AM

Re: Disable open_file_cache for a specific location

Francis DalyJuly 03, 2013 06:18PM

Re: Disable open_file_cache for a specific location

PelekeJuly 04, 2013 03:16AM

Re: Disable open_file_cache for a specific location

Jonathan MatthewsJuly 04, 2013 08:32AM

Re: Disable open_file_cache for a specific location

PelekeJuly 05, 2013 03:24AM

Re: Disable open_file_cache for a specific location

PelekeJuly 07, 2013 04:27PM

Re: Disable open_file_cache for a specific location

Francis DalyJuly 08, 2013 01:10PM

Re: Disable open_file_cache for a specific location

PelekeJuly 08, 2013 03:42PM

Re: Disable open_file_cache for a specific location

Francis DalyJuly 08, 2013 06:06PM

Re: Disable open_file_cache for a specific location

PelekeJuly 09, 2013 03:34AM

Re: Disable open_file_cache for a specific location

Francis DalyJuly 10, 2013 05:26PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 78
Record Number of Users: 7 on March 06, 2014
Record Number of Guests: 184 on July 08, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready