Welcome! Log In Create A New Profile

Advanced

adding expires but not show up in headers

June 19, 2013 12:03AM
Hi,

I added a expires as follow:

location ~ ^/images/ {
root /var/www
expires max;
}

if I do a curl -I http://localhost/images/sample.jpg, I got following headers, but can not find the "Expires" in the headers, what I did wrong here? Thanks.

HTTP/1.1 200 OK
Server: nginx/1.4.1
Date: Wed, 19 Jun 2013 03:52:13 GMT
Content-Type: image/jpeg
Content-Length: 17584
Last-Modified: Wed, 19 Jun 2013 02:12:31 GMT
Connection: keep-alive
ETag: "51c1138f-44b0"
Accept-Ranges: bytes
SubjectAuthorPosted

adding expires but not show up in headers

angelochen960June 19, 2013 12:03AM

Re: adding expires but not show up in headers

Francis DalyJune 19, 2013 04:06AM

Re: adding expires but not show up in headers

angelochen960June 19, 2013 05:28AM

Re: adding expires but not show up in headers

Maxim DouninJune 19, 2013 06:20AM

Re: adding expires but not show up in headers (SOLVED)

angelochen960June 19, 2013 06:40AM

Re: adding expires but not show up in headers

Francis DalyJune 19, 2013 07:04AM

Re: adding expires but not show up in headers

angelochen960June 19, 2013 05:31AM

Re: adding expires but not show up in headers

smith121June 28, 2013 01:19AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 87
Record Number of Users: 7 on March 06, 2014
Record Number of Guests: 229 on August 01, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready