Welcome! Log In Create A New Profile

Advanced

Disable automatic urlencoding with proxy_pass

May 09, 2013 05:37AM
Hi,

Any way to disable urlencode on nginx with proxy_pass? Following is my config and as suggested on google I already removed the "/" URI part of
of this "proxy_pass http://127.0.0.1:8090;"

Any idea how to proceed with this?

server {
### server port and name ###
listen 10.0.0.1:443 ssl;
server_name svn.server;

### SSL cert files ###
ssl_certificate /etc/pki/tls/certs/svn.server.cert;
ssl_certificate_key /etc/pki/tls/private/svn.server.key;
ssl_session_cache shared:SSL:10m;

location / {
proxy_pass http://127.0.0.1:8090;
proxy_redirect off;

set $fixed_destination $http_destination;
if ( $http_destination ~* ^https(.*)$ )
{
set $fixed_destination http$1;
}

### Set headers ####
proxy_set_header Host $http_host:$proxy_port;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto https;
proxy_set_header Destination $fixed_destination;
}
}


Thanks

lupin
SubjectAuthorPosted

Disable automatic urlencoding with proxy_pass

lupinMay 09, 2013 05:37AM

Re: Disable automatic urlencoding with proxy_pass

Francis DalyMay 09, 2013 06:44PM

Re: Disable automatic urlencoding with proxy_pass

Matthieu TourneMay 09, 2013 07:04PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 74
Record Number of Users: 5 on December 17, 2014
Record Number of Guests: 154 on December 17, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready