Welcome! Log In Create A New Profile

Advanced

Re: how to disable nginx internal dns cache?

May 06, 2013 09:31AM
i have resolver define, see below configuration:

server {
listen 80;
server_name xx.com;
access_log /var/log/nginx/xx-nginx.access.log;
error_log /var/log/nginx/xx-nginx_error.log debug;

# resolver 8.8.8.8;
# resolver_timeout 1s;

#set your default location
location / {
# resolver 8.8.8.8 valid=5s; # i have defined resolver at here ,and also tried to add it in "http" section in nginx.conf file. but both of them doesnt work.
proxy_pass http://p2.domain.com;
}

#error_page 404 /404.html;
# redirect server error pages to the static page /50x.html
#
error_page 500 502 503 504 /50x.html;
location = /50x.html {
root /var/www;
}
}
SubjectAuthorPosted

how to disable nginx internal dns cache?

nevernetMay 04, 2013 08:42AM

Re: how to disable nginx internal dns cache?

Francis DalyMay 04, 2013 09:06AM

Re: how to disable nginx internal dns cache?

nevernetMay 06, 2013 09:31AM

RE: how to disable nginx internal dns cache?

Lukas TribusMay 06, 2013 09:54AM

Re: how to disable nginx internal dns cache?

Maxim DouninMay 06, 2013 10:00AM

Re: how to disable nginx internal dns cache?

nevernetMay 07, 2013 04:51AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 67
Record Number of Users: 7 on March 06, 2014
Record Number of Guests: 229 on August 01, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready