Welcome! Log In Create A New Profile

Advanced

nginx_upload_progress

March 14, 2013 10:47PM
I'm trying to compile in the nginx_upload_progress module into an RPM. I'm using the SPEC file provided with v1.2.7 from the Nginx repos. I downloaded the upload_progress module, opened up the source tar archive, copied the module to nginx-1.2.7/nginx-upload-progress-module, and added this line to my SPEC file:

--add-module=%{_builddir}/%{name}-%{version}/nginx-upload-progress-module \

When run the rpmbuild process, it looks to me like it is successfully finding and compiling the module (excerpts from the build log):


gcc -c -pipe -O -W -Wall -Wpointer-arith -Wno-unused-parameter -Werror -g -O2 -g -I src/core -I src/event -I src/event/modules -I src/os/unix -I objs -I src/http -I src/http/modules -I src/mail \
-o objs/addon/nginx-upload-progress-module/ngx_http_uploadprogress_module.o \
/root/rpmbuild/BUILD/nginx-1.2.7/nginx-upload-progress-module/ngx_http_uploadprogress_module.c

objs/addon/nginx-upload-progress-module/ngx_http_uploadprogress_module.o \

Checking for unpackaged file(s): /usr/lib/rpm/check-files /root/rpmbuild/BUILDROOT/nginx-1.2.7-1.el6.ngx.x86_64
Wrote: /root/rpmbuild/SRPMS/nginx-1.2.7-1.el6.ngx.src.rpm
Wrote: /root/rpmbuild/RPMS/x86_64/nginx-1.2.7-1.el6.ngx.x86_64.rpm
Wrote: /root/rpmbuild/RPMS/x86_64/nginx-debug-1.2.7-1.el6.ngx.x86_64.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.tN7cRa
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd nginx-1.2.7
+ /bin/rm -rf /root/rpmbuild/BUILDROOT/nginx-1.2.7-1.el6.ngx.x86_64
+ exit 0


So, the build completes successfully, but when I install the rpm and run "nginx -V", I get:

nginx version: nginx/1.2.7
built by gcc 4.4.6 20120305 (Red Hat 4.4.6-4) (GCC)
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_stub_status_module --with-mail --with-mail_ssl_module --with-file-aio --with-ipv6 --with-cc-opt='-O2 -g'

... no upload-progress module.

Am I missing a part of the process here?

Thanks!
SubjectAuthorPosted

nginx_upload_progress

jaychrisMarch 14, 2013 10:47PM

Re: nginx_upload_progress

jaychrisMarch 15, 2013 01:18PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 64
Record Number of Users: 5 on December 17, 2014
Record Number of Guests: 154 on December 17, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready