Welcome! Log In Create A New Profile

Advanced

Re: nginx: [emerg] invalid host in upstream

March 14, 2013 02:19PM
It looks like Bitnami expects the Rails app to be in url/appname. So, I just removed the /ndeavor from the thin.yml and from nginx.conf.

This is what my thin.yml looks like now: https://dl.dropbox.com/u/35302780/thin.yml

And this is my nginx.conf: https://dl.dropbox.com/u/35302780/nginx.conf

I'm using Bitnami Rails stack that runs Ubuntu.

I now start the Thin with this: thin -C thin.yml start

And I start Nginx with this: bitnami@linux:/opt/bitnami$ sudo ./ctlscript.sh start nginx

And they both start OK.

But, when I go to my website url, I get this message "The service is not available. Please try again later."

I don't know where that message is coming from.
SubjectAuthorPosted

nginx: [emerg] invalid host in upstream

ReddirtMarch 14, 2013 11:19AM

Re: nginx: [emerg] invalid host in upstream

w.bMarch 14, 2013 11:26AM

Re: nginx: [emerg] invalid host in upstream

WolfsrudelMarch 14, 2013 12:06PM

Re: nginx: [emerg] invalid host in upstream

ReddirtMarch 14, 2013 02:19PM

Re: nginx: [emerg] invalid host in upstream

ReddirtMarch 14, 2013 02:24PM

Re: nginx: [emerg] invalid host in upstream

ReddirtMarch 14, 2013 02:27PM

Re: nginx: [emerg] invalid host in upstream

ReddirtMarch 14, 2013 04:13PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 93
Record Number of Users: 3 on November 23, 2014
Record Number of Guests: 377 on November 23, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready