Welcome! Log In Create A New Profile

Advanced

Re: FastCGI cache has stopped working

March 03, 2013 08:02AM
Maxim Dounin Wrote:
-------------------------------------------------------
> In ths particular case I would suggest there is another caching
> layer, which results in cached "X-Cache: MISS" being returned.
> Note that Expires and Last-Modified are the same, and
> X-ExecutionTime headers match exactly:

Yeah, for that particular page there's another caching layer in the app itself. The X-Cache header is added by Nginx, however (tested this by renaming it in my Nginx configuration).

Try http://dan.cx/bundles/main.css instead - This file does not have another caching layer, and you can see the Last-Modified and Expires headers changing on every request.

As far as I can tell, this is a bug in Nginx (looks like it's not parsing the Expires date correctly if the day is a single digit) and I've raised it in Trac: http://trac.nginx.org/nginx/ticket/310
SubjectAuthorPosted

FastCGI cache has stopped working

Daniel15March 03, 2013 07:32AM

Re: FastCGI cache has stopped working

Daniel15March 03, 2013 07:45AM

Re: FastCGI cache has stopped working

Maxim DouninMarch 03, 2013 07:58AM

Re: FastCGI cache has stopped working

Daniel15March 03, 2013 08:02AM

Re: FastCGI cache has stopped working

Maxim DouninMarch 03, 2013 08:08AM

Re: FastCGI cache has stopped working

Maxim DouninMarch 03, 2013 08:06AM

Re: FastCGI cache has stopped working

Daniel15March 04, 2013 06:53AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 100
Record Number of Users: 7 on March 06, 2014
Record Number of Guests: 165 on April 21, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready