Welcome! Log In Create A New Profile

Advanced

nginx can't run php only 'PAGE NOT FOUND'

February 19, 2013 05:13AM
I'm sorry for my English...

nginx has default html page it's /usr/share/nginx/html.
But I changed custom new path it's /home/norrent/public_html.

If I put php and html files in the original path, works well.
But if I put php and html files in the custom path, only html files work.
and php files show me up 'Page Not Found'
then nginx record error message

************************
[error] 2478#0: *19 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream,
client: XX.XXX.XX.XXX, server: lo blah~blah~blah~~~~~~~
************************

I thins I seted some wrong configuration.
please check this nginx.conf file;
***************************************
/etc/nginx/nginx.conf
***************************************
server {
listen 80;
server_name localhost;
root /home/norrent/public_html;

location / {
index index.php index.html index.htm;
}

location ~ \.php$ {
set $php_root /home/norrent/public_html;
fastcgi_pass unix:/tmp/php-fpm.sock;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $php_root$fastcgi_script_name;
include fastcgi_params;
}
}

***************************************
/etc/nginx/fastcgi_params
***************************************
fastcgi_param QUERY_STRING $query_string;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;

fastcgi_param SCRIPT_NAME $fastcgi_script_name;
fastcgi_param REQUEST_URI $request_uri;
fastcgi_param DOCUMENT_URI $document_uri;
fastcgi_param DOCUMENT_ROOT $document_root;
fastcgi_param SERVER_PROTOCOL $server_protocol;
fastcgi_param HTTPS $https if_not_empty;

fastcgi_param GATEWAY_INTERFACE CGI/1.1;
fastcgi_param SERVER_SOFTWARE nginx/$nginx_version;

fastcgi_param REMOTE_ADDR $remote_addr;
fastcgi_param REMOTE_PORT $remote_port;
fastcgi_param SERVER_ADDR $server_addr;
fastcgi_param SERVER_PORT $server_port;
fastcgi_param SERVER_NAME $server_name;

# PHP only, required if PHP was built with --enable-force-cgi-redirect
fastcgi_param REDIRECT_STATUS 200;


Thank you for nginx and forum!
SubjectAuthorPosted

nginx can't run php only 'PAGE NOT FOUND'

leejaycokeFebruary 19, 2013 05:13AM

Re: nginx can't run php only 'PAGE NOT FOUND'

GreenGeckoFebruary 19, 2013 05:24AM

Re: nginx can't run php only 'PAGE NOT FOUND'

leejaycokeFebruary 19, 2013 06:56AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 70
Record Number of Users: 5 on November 05, 2014
Record Number of Guests: 210 on November 05, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready