Welcome! Log In Create A New Profile

Advanced

Re: SPDY + proxy cache static content failures

April 02, 2013 06:49PM
Hi guys,

So perhaps I shouldn't have reused my existing topic and confused things, sorry!

I only did so because the symptom is exactly the same as the issue I originally reported (SOME static content served from proxy cache occasionally doesn't make it to Firefox when using SPDY). If you disable either SPDY or the proxy cache the problem stops happening.

The originally reported problem stopped occurring after a fix was implemented, but now I'm seeing it again since I put haproxy as the upstream (to get enhanced health checks etc).

The difference this time is that I'm not seeing the 499 errors (or 444) in the nginx log. I'm not returning 444 (via config) in these scenarios either.

Firefox shows this:

GET https://whatever/postrequest [HTTP/1.1 200 OK 45ms]
GET https://whatever/css1 [HTTP/1.1 304 OK 25ms]
GET https://whatever/css2 [HTTP/1.1 304 OK 260ms]
GET https://whatever/js1 [HTTP/1.1 304 OK 260ms]
GET https://whatever/js2 [HTTP/1.1 304 OK 35ms]
GET https://whatever/image1 [HTTP/1.1 304 OK 40ms]
GET https://whatever/image2 [HTTP/1.1 304 OK 40ms]
GET https://whatever/image3 [HTTP/1.1 304 OK 40ms]
GET https://whatever/image4 [HTTP/1.1 304 OK 40ms]
GET https://whatever/image5 [5ms]
GET https://google.com/analyticsjs [HTTP/1.1 304 Not Modified 50ms]
GET https://whatever/image6 [0ms]
GET https://whatever/image7 [0ms]
GET https://whatever/image8 [0ms]
GET https://whatever/image9 [0ms]
GET https://whatever/image10 [0ms]

So you can see that around the time it loads the 5th image things go wrong and the 5th onward images all have no content. Firefox detail shows no response headers/content for the 5th image onward.

The Haproxy and Nginx logs show 304 successfully for all of these requests, so I guess the connection is dropped somewhere and Nginx isn't picking it up and still thinks it worked fine.

Any suggestions on how to proceed further on this? Happy to provide specific details/logs via email if required.

Thanks,

spdyg
SubjectAuthorPosted

Re: SPDY + proxy cache = occasional 499 errors

Valentin V. BartenevDecember 03, 2012 08:16AM

Re: SPDY + proxy cache = occasional 499 errors

spdygApril 02, 2013 06:54AM

Re: SPDY + proxy cache = occasional 499 errors

Valentin V. BartenevApril 02, 2013 09:18AM

Re: SPDY + proxy cache = occasional 499 errors

Maxim DouninApril 02, 2013 10:48AM

Re: SPDY + proxy cache = occasional 499 errors

Valentin V. BartenevApril 02, 2013 11:22AM

Re: SPDY + proxy cache static content failures

spdygApril 02, 2013 06:49PM

Re: SPDY + proxy cache static content failures

Valentin V. BartenevApril 03, 2013 06:22PM

Re: SPDY + proxy cache static content failures

spdygApril 03, 2013 06:43PM

Re: SPDY + proxy cache static content failures

Valentin V. BartenevApril 05, 2013 06:58AM

Re: SPDY + proxy cache static content failures

spdygApril 08, 2013 08:16AM

Re: SPDY + proxy cache static content failures

David GwynneJuly 22, 2013 07:44AM

Re: SPDY + proxy cache static content failures

spdygJuly 24, 2013 07:36AM

Re: SPDY + proxy cache static content failures

JStlNovember 14, 2013 12:41PM

Re: SPDY + proxy cache static content failures

spdygNovember 16, 2013 07:03AM

Re: SPDY + proxy cache static content failures

ruben.heroldNovember 26, 2013 03:34PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 72
Record Number of Users: 7 on March 06, 2014
Record Number of Guests: 229 on August 01, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready