Welcome! Log In Create A New Profile

Advanced

SPDY + proxy_cache = occasional 499 errors

December 01, 2012 06:48PM
Hi there,

I have been piloting the SPDY patch on a separate web server pointing to an existing HTTP backend.

With just myself using this pilot web server, occasionally static resources such as css or images are not loading in Firefox (usually when pressing F5 to reload a page)

Have done a bit of digging and have learnt this so far:

When issue occurs in Firefox, access log is showing 499 errors for the missing static resources (when it should be 304)
Refreshing the page will eventually load the resources (and they will show 304 in the access log)
If I turn off the proxy cache for these static resources, the issue stops
If I turn off SPDY, the issue stops.
The issue obviously doesn't occur on the production web server running Nginx 1.2.x

Has this been seen before, or can you think of any reason why this might happen?

I don't normally use Chrome but have also witnessed this once in Chrome, so I don't think it's browser specific (however will try to get more confidence of this).

Thanks.
SubjectAuthorPosted

SPDY + proxy_cache = occasional 499 errors

spdygDecember 01, 2012 06:48PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 89
Record Number of Users: 5 on December 17, 2014
Record Number of Guests: 154 on December 17, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready