Welcome! Log In Create A New Profile

Advanced

Re: nginx erroneously redirecting to https

October 07, 2012 09:42AM
Piki Wrote:
-------------------------------------------------------
> I am running nginx+php-fpm on localhost for testing some stuff sites
> before uploading to a live server (which I have done with nginx in the
> past), and have run into the first issue which Google can't seem to
> help me with:
>
> I have decided to try three different forum softwares. They are
> installed under separate subdirectories within my web root (e.g.
> /srv/www/localhost/html/{forum1,forum2,forum3}). On two of the forums,
> however, whenver I try to use anything that requires a password, it
> switches from http to https, and on one of the forums, attempts to
> continue using port 80. On the forum that it attempts to use port 80,
> I get the following error message:
>
> ----------code snippet----------
> Secure Connection Failed
>
> An error occurred during a connection to localhost:80.
>
> SSL received a record that exceeded the maximum permissible length.
>
> (Error code: ssl_error_rx_record_too_long)
>
> The page you are trying to view cannot be shown because the
> authenticity of the received data could not be verified.
> Please contact the website owners to inform them of this problem.
> Alternatively, use the command found in the help menu to report this
> broken site.
> ----------end code snippet----------
>
> I do not have https or ssl configured within nginx or the vhost, nor
> any ssl certs.
>
> Here is the vhost config file:
> ----------code snippet----------
> server {
> server_name localhost;
> listen 80;
> root /srv/www/localhost/html;
> index index.php index.html index.htm;
> ssi on;
>
> location ~ \.php$ {
> include /etc/nginx/fastcgi_params;
> fastcgi_index index.php;
> fastcgi_pass 127.0.0.1:9000;
> }
> }
> ----------end code snippet----------

This issue seems to have fixed itself after I added the "ssl off;" directive (without quotes) to the above server block. After I restarted nginx, I cleared out and reinstalled the affected forum software, and the issue hasn't reappeared yet, not even after clearing my browser cache, rebooting the computer, then revisiting the forums.

I though "ssl off;" was supposed to be the default if the ssl setting isn't specified?

--
Piki
SubjectAuthorPosted

nginx erroneously redirecting to https

PikiOctober 04, 2012 06:07AM

Re: nginx erroneously redirecting to https

PikiOctober 04, 2012 07:00AM

Re: nginx erroneously redirecting to https

PikiOctober 07, 2012 09:42AM

Re: nginx erroneously redirecting to https

GulaholicDecember 21, 2012 11:05AM

Re: nginx erroneously redirecting to https

Francis DalyDecember 21, 2012 02:22PM

Re: nginx erroneously redirecting to https

GulaholicDecember 22, 2012 12:00PM

Re: nginx erroneously redirecting to https

GulaholicDecember 27, 2012 11:27AM

Re: nginx erroneously redirecting to https

Edho AriefDecember 22, 2012 12:06PM

Re: nginx erroneously redirecting to https

Вадим ЛазовскийDecember 22, 2012 04:46PM

Re: nginx erroneously redirecting to https

GulaholicDecember 27, 2012 11:30AM

Re: nginx erroneously redirecting to https

Francis DalyDecember 23, 2012 06:12AM

Re: nginx erroneously redirecting to https

Francis DalyDecember 29, 2012 09:28AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 81
Record Number of Users: 7 on March 06, 2014
Record Number of Guests: 229 on August 01, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready