Welcome! Log In Create A New Profile

Advanced

X-Accel-Redirect testing

September 25, 2012 06:28PM
Hello,
I'd like to test if I set up my configs properly and if they're working.
Should it work if I send a GET request with the X-Accel-Redirect header?
I am using Mozilla plugin "Modify Headers". I have added: "X-Accel-Redirect /index" and my request on the server is:
(captured with tcpdump)
---
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip, deflate
Connection: keep-alive
X-Accel-Redirect: /index
---
My vhost config in nginx is:
---
server {
listen 80;
server_name aa.com; #it's added in my hosts file
location / {
alias /var/www;
internal;
}
}
---

Path is:
---
ls -lh /var/www/
index
---
Error is 404 Not Found - nothing logged in error.log though ...

My environment would actually be Apache as frontend which passes requests with X-Accel-Redirect to Nginx which serves static files.
But right now I'm in testing phase.
SubjectAuthorPosted

X-Accel-Redirect testing

w00tSeptember 25, 2012 06:28PM

Re: X-Accel-Redirect testing

Jonathan MatthewsSeptember 25, 2012 07:08PM

Re: X-Accel-Redirect testing

w00tSeptember 26, 2012 04:17AM

Re: X-Accel-Redirect testing

António P. P. AlmeidaSeptember 26, 2012 05:04AM

Re: X-Accel-Redirect testing

nginxorgSeptember 26, 2012 05:12AM

Re: X-Accel-Redirect testing

w00tOctober 02, 2012 08:01AM

Re: X-Accel-Redirect testing

António P. P. AlmeidaOctober 02, 2012 08:20AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 101
Record Number of Users: 7 on March 06, 2014
Record Number of Guests: 156 on March 20, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready