Welcome! Log In Create A New Profile

Advanced

502 Bad Gateway - Wordpress

February 22, 2012 03:32PM
Greetings,

I'm having another issue with my nginx + php-fpm + mysql install. I've been having a lot of issues today after fixing my previous one and I've finally decided that I am stumped on this one.

Ok, so I am trying to install WordPress on my server that I have nginx + php-fpm installed on but every time I navigate to http://mydomain.com/wp-admin/install.php I recieve an error: 502 Bad Gateway. I checked out my error logs and I saw this:

2012/02/22 10:02:54 [error] 2801#0: *114 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: m.y.i.p, server: mydomain.com, request: "GET /wp-admin/install.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "mydomain.com"

I have checked to see if php-fpm is running and is listening on port 9000 and it is in fact running and listening. I can view phpinfo() pages just fine.

I did have my php-fpm set up to listen on a unix socket(?) and it was doing that so I switched back to TCP and it's still doing it, I receive the same error for both of them only with the different upstream.

Any help would be greatly appreciate, I've had such troubles today..

Thanks,
Jeremiah!
SubjectAuthorPosted

502 Bad Gateway - Wordpress

JerWFebruary 22, 2012 03:32PM

Re: 502 Bad Gateway - Wordpress

JerWFebruary 22, 2012 04:25PM

Re: 502 Bad Gateway - Wordpress

JerWFebruary 22, 2012 04:41PM

Re: 502 Bad Gateway - Wordpress

JerWFebruary 23, 2012 11:45AM

Re: 502 Bad Gateway - Wordpress

corbyNovember 07, 2012 10:00AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 93
Record Number of Users: 7 on March 06, 2014
Record Number of Guests: 229 on August 01, 2014
Powered by nginx    Powered by FreeBSD    PHP Powered    Powered by Percona     ipv6 ready